Results 1 to 25 of 25

Thread: Fixing Beam Blaster/Artilliray...

  1. #1
    Widget biscuit boy's Avatar
    Join Date
    Apr 2010
    Location
    vancouver b.c.
    Posts
    26

    Fixing Beam Blaster/Artilliray...

    Has anyone had any success repairing one? I am on my 3rd, this one fresh outta box, worked a couple times then the platform will not lift. Like another I own it just grinds. Anybody have any help? Thanks in advance.

  2. #2
    Heroic Warrior Night Stalker's Avatar
    Join Date
    Sep 2011
    Posts
    447
    I have yet to come across one that works. I took one apart to try and fix it and despite being very, very, VERY careful, it broke while I was trying to get it loose (the gun platform... I forget which one's the BB and which one's the Artilleray...)

    The two accessories that I have the worst luck with finding in good working order are the Dragon Walker and BB/Artilleray. Cliff Climber and Scubattack aren't far behind them.
    1 of 200 active He-Man.org members.

  3. #3
    Widget biscuit boy's Avatar
    Join Date
    Apr 2010
    Location
    vancouver b.c.
    Posts
    26
    I was wondering about that, the platform seems awfully rigid. I have been lucky with Walkers, but I hear you on those Scuba/Climber/Tower tools motors. I should start a thread asking if anyone knows how to fix those dumb lil' things.

  4. #4
    Heroic Warrior beastor's Avatar
    Join Date
    Dec 2010
    Location
    CA
    Posts
    585
    I have never had a BB/AR that worked . Out of ~20 Dragon Walkers I have had, all but probably two have worked. The vehicle I have the most trouble finding in working order is Spydor!
    My sell/trade list - vintage 80's toys - adding stuff all the time! http://www.blujay.com/beastor

    My feedback thread. http://www.he-man.org/forums/boards/...d.php?t=202525

    My want list http://www.he-man.org/forums/boards/...70#post2849070

  5. #5
    Assimilate, or else!! krosfyah's Avatar
    Join Date
    May 2001
    Location
    Under an iron fist
    Posts
    17,965
    when I bought my BB/AR they worked great! had em stored for years and it stopped I tried to fixed it, but just made things worse, my dragon walker however is still perfect! runs like it was right off the lot!
    CHECK OUT MY BRAND NEW WEBSITE for my Akil and Saltfish comic strip, more to come soon!

    I've got everything that I need, right in front of me! Life's a happy song people!

    Fear is faith in failure

  6. #6
    Heroic Warrior Night Stalker's Avatar
    Join Date
    Sep 2011
    Posts
    447
    Quote Originally Posted by beastor View Post
    I have never had a BB/AR that worked . Out of ~20 Dragon Walkers I have had, all but probably two have worked. The vehicle I have the most trouble finding in working order is Spydor!
    I'm the exact opposite... all my Spydors worked but none of the Dragon Walkers do!

    I've gathered about ten Dragon Walkers in the last few years, and none of them have worked. Almost all of them still had 25 year old batteries that leaked acid and corroded the compartment. I've had three Spydors though and all of them still work, even though two are missing the front left legs.
    1 of 200 active He-Man.org members.

  7. #7
    Widget biscuit boy's Avatar
    Join Date
    Apr 2010
    Location
    vancouver b.c.
    Posts
    26
    The first person I have heard tell of a working Artilliray! Before it packed it in did it actually toss figure off the platform? I am saddened by the news here. I was really hoping to get one of the four sitting here to work.

    Quote Originally Posted by krosfyah View Post
    when I bought my BB/AR they worked great! had em stored for years and it stopped I tried to fixed it, but just made things worse, my dragon walker however is still perfect! runs like it was right off the lot!

  8. #8
    Widget biscuit boy's Avatar
    Join Date
    Apr 2010
    Location
    vancouver b.c.
    Posts
    26
    The first person I have heard tell of a working Artilliray! Before it packed it in did it actually toss figure off the platform? I am saddened by the news here. I was really hoping to get one of the four sitting here to work.

    Quote Originally Posted by krosfyah View Post
    when I bought my BB/AR they worked great! had em stored for years and it stopped I tried to fixed it, but just made things worse, my dragon walker however is still perfect! runs like it was right off the lot!

  9. #9
    Oz-Man deviusrme's Avatar
    Join Date
    Apr 2011
    Location
    Brisbane, Australia
    Posts
    39
    Artilleray fix.JPG

    Hi, I spent a long time trying to fix mine and this is the solution I found that works for the gear grinding sound (this was the problem I found in mine, not saying that it is definitely the same issue for you)

    ** Note: if you are going to try and attempt this, putting the platform spring back in is extremely difficult, don't say I didn't warn you, read through first before taking yours apart**

    In the photo above you will see a small red cap, you won't see this in any other Artilleray, (you will need to find, or make something of equivalent, I found this one in an old vcr, just lucky that hole though it was the same size as the shaft)
    I slid this onto the opposite end of the shaft with the large gear on it, in order to do this I had to push the shaft back through the large gear just a little bit, so that it stuck out the other side of the grey housing, allowing me something to slide the cap onto (it was a tight fit so I didn't need any glue). This now prevents the shaft with the large gear on it from moving across and sliding off the smaller gear. Mine now works every time. Just remember that when you go to take this apart that you take extra care in seeing how the platform spring is put in, I didn't check when I pulled mine apart, and it near killed me trying to work out where to put it back (**note the spring in the photo is not the platform spring, I am referring to). Sorry but I did this fix about 8 months ago and I don't have any photos for how the spring went in. But if you are pretty handy and have a bit of patience, then I suggest you give this a try, if its already broken then you don't have anything to loose, that was the approach I took anyway. I hope this helps
    Last edited by deviusrme; March 28, 2012 at 04:01am. Reason: More info

  10. #10
    Oz-Man deviusrme's Avatar
    Join Date
    Apr 2011
    Location
    Brisbane, Australia
    Posts
    39
    loosely attach this screw.JPGspring position example.JPGspring position finished 2.JPGspring position finished 3.JPGspring position finished.JPG

    Ok, So I got bored and decided to pull apart my Artilleray and try and get some photos together to try and help you guys out. (these instructions are just for the platform spring)
    **Remember once it is open it can be tricky to put back together, I warned you**
    Key points for reassembly, Be patient, it can be difficult
    Loosely reattach the white hook before trying to seat the blue platform into position, Blue platform comes in from the top of the casing, and make sure the part of the spring shown in the photos is between the platform and outer casing
    As you tighten the screw that holds the white hook (this is the one screw that is different) don't stress if the spring falls of the ledge, as you can fix this up before screwing the two halves back together (two people may be required to assist holding it all as you tighten the hook screw)
    Check the spring is in it's correct position before putting the two halves back together, last thing you want to do is take it apart again

    Also it's probably a good idea to have a look around inside to make sure all wires are connected well, while its all open
    If you need any more info flick me a PM

  11. #11
    Oz-Man deviusrme's Avatar
    Join Date
    Apr 2011
    Location
    Brisbane, Australia
    Posts
    39
    spring position.jpg

    One more pic and a video of it working
    One last thing, mine was working when I bought it, then stopped after a couple of goes, I was pretty annoyed, I then decided to have a crack at fixing it, hope this can help a few fellow org members
    Last edited by deviusrme; March 28, 2012 at 07:49am.

  12. #12
    Assimilate, or else!! krosfyah's Avatar
    Join Date
    May 2001
    Location
    Under an iron fist
    Posts
    17,965
    Quote Originally Posted by deviusrme View Post
    spring position.jpghttps://www.facebook.com/video/video...=3758964736363

    One more pic and a video of it working
    One last thing, mine was working when I bought it, then stopped after a couple of goes, I was pretty annoyed, I then decided to have a crack at fixing it, hope this can help a few fellow org members
    Quote Originally Posted by biscuit boy View Post
    The first person I have heard tell of a working Artilliray! Before it packed it in did it actually toss figure off the platform? I am saddened by the news here. I was really hoping to get one of the four sitting here to work.
    yep it worked JUST like in that video, I had fun with it as a kid. that sounds takes me back! good times for sure.
    i think my spring is lost now, I'm going to see if I can find one, make it a project to fix it.
    CHECK OUT MY BRAND NEW WEBSITE for my Akil and Saltfish comic strip, more to come soon!

    I've got everything that I need, right in front of me! Life's a happy song people!

    Fear is faith in failure

  13. #13
    Heroic Warrior beastor's Avatar
    Join Date
    Dec 2010
    Location
    CA
    Posts
    585
    Quote Originally Posted by deviusrme View Post
    loosely attach this screw.JPGspring position example.JPGspring position finished 2.JPGspring position finished 3.JPGspring position finished.JPG

    Ok, So I got bored and decided to pull apart my Artilleray and try and get some photos together to try and help you guys out. (these instructions are just for the platform spring)
    **Remember once it is open it can be tricky to put back together, I warned you**
    Key points for reassembly, Be patient, it can be difficult
    Loosely reattach the white hook before trying to seat the blue platform into position, Blue platform comes in from the top of the casing, and make sure the part of the spring shown in the photos is between the platform and outer casing
    As you tighten the screw that holds the white hook (this is the one screw that is different) don't stress if the spring falls of the ledge, as you can fix this up before screwing the two halves back together (two people may be required to assist holding it all as you tighten the hook screw)
    Check the spring is in it's correct position before putting the two halves back together, last thing you want to do is take it apart again

    Also it's probably a good idea to have a look around inside to make sure all wires are connected well, while its all open
    If you need any more info flick me a PM
    Very well documented! Mine won't even power up with batteries (no grinding sound or anything) so I probably won't try to save it.
    My sell/trade list - vintage 80's toys - adding stuff all the time! http://www.blujay.com/beastor

    My feedback thread. http://www.he-man.org/forums/boards/...d.php?t=202525

    My want list http://www.he-man.org/forums/boards/...70#post2849070

  14. #14
    Widget biscuit boy's Avatar
    Join Date
    Apr 2010
    Location
    vancouver b.c.
    Posts
    26
    You, my dear deviusrme, are a champion. Thank you kindly for the effort, I will give it a go on the weekend. If this works for me, I may be lousy with working BB/AR's, as all of mine grind. Thanks again.

  15. #15
    Oz-Man deviusrme's Avatar
    Join Date
    Apr 2011
    Location
    Brisbane, Australia
    Posts
    39
    Quote Originally Posted by biscuit boy View Post
    You, my dear deviusrme, are a champion. Thank you kindly for the effort, I will give it a go on the weekend. If this works for me, I may be lousy with working BB/AR's, as all of mine grind. Thanks again.
    That grinding sound will still probably be there, even after you have fixed it, if you watch the video you will hear mine grinding away, it's more the slipping of the gears that I found to be the problem, as far as I can tell the grinding noise to some extent is normal, I don't know if anyone else can confirm this for me. Good luck repairing yours, I hope this is helpful, I love this toy and will try anything and everything to keep it going for years to come.

  16. #16
    Oz-Man deviusrme's Avatar
    Join Date
    Apr 2011
    Location
    Brisbane, Australia
    Posts
    39
    Quote Originally Posted by beastor View Post
    Very well documented! Mine won't even power up with batteries (no grinding sound or anything) so I probably won't try to save it.
    The other one of these that I had repaired, all the wires inside both units were corroded and perished, my old man (rest his Heart) was good with electronics and rewired parts of it to get it working again for me. Also, I know this may sound simple, but there is an on/off switch on the larger unit, don't take this the wrong way, not trying to say your dumb or something, but it could be something as simple as that.

  17. #17
    Widget biscuit boy's Avatar
    Join Date
    Apr 2010
    Location
    vancouver b.c.
    Posts
    26
    An on/off switch? Er... Nah, I kid, I am aware of the switch.

    I am an electrician by trade, so I may be able to rewire anything hinky inside. But I have a feeling it is the gears slipping, as my latest one came fresh out of the box and worked twice. It makes the same noise as two others that I have, so I have an inkling that the grinding is normal, but we shall see this weekend.

    I am happy to have your feedback before I went into one of them, thanks.

  18. #18
    Assimilate, or else!! krosfyah's Avatar
    Join Date
    May 2001
    Location
    Under an iron fist
    Posts
    17,965
    the grinding is normal, as I said the sound takes me back, it made that sound everytime and mine worked at least up until I packed them away for years.
    CHECK OUT MY BRAND NEW WEBSITE for my Akil and Saltfish comic strip, more to come soon!

    I've got everything that I need, right in front of me! Life's a happy song people!

    Fear is faith in failure

  19. #19
    Heroic Warrior darkchina811's Avatar
    Join Date
    Jun 2012
    Location
    ITALY
    Posts
    204
    I am trying to fix mine too, our australian friend's pictures are helpful but still I do not understand where the spring goes. ok, one side is between the blue platform and the top half on the gray casing but what about the other side of the spring? you say something about "don't worry if it falls down, you can put a screwdriver..."... I am sorry I do not understand.

    I mean, I have put it back altogether and it would work too, but the platform is not spring-loaded. the other side of the spring should be "pushing" somewhere to rest the spring in tension but I don't understand where to hook it.
    Last edited by darkchina811; June 13, 2012 at 10:39am.

  20. #20
    Heroic Warrior darkchina811's Avatar
    Join Date
    Jun 2012
    Location
    ITALY
    Posts
    204
    anybody...? PLEASE !!!
    He-Man & She-Ra... ma se lui uomo, perchè lei RA???

  21. #21
    Heroic Warrior darkchina811's Avatar
    Join Date
    Jun 2012
    Location
    ITALY
    Posts
    204
    my BB has been sold and I had to sell it as broken because I couldn't figure how to put the spring back. thank you everybody.
    He-Man & She-Ra... ma se lui uomo, perchè lei RA???

  22. #22
    Widget
    Join Date
    Aug 2012
    Location
    Bosnia and Herzegovina
    Posts
    11
    Quote Originally Posted by deviusrme View Post
    spring position.jpghttps://www.facebook.com/video/video...=3758964736363

    One more pic and a video of it working
    One last thing, mine was working when I bought it, then stopped after a couple of goes, I was pretty annoyed, I then decided to have a crack at fixing it, hope this can help a few fellow org members
    Works only with lighter figures attempt with Masters.
    It is impossible that the platform can ejact figure, spring is to weak.
    Last edited by Dinostula; August 23, 2012 at 02:27pm.

  23. #23
    Oz-Man deviusrme's Avatar
    Join Date
    Apr 2011
    Location
    Brisbane, Australia
    Posts
    39
    Quote Originally Posted by Dinostula View Post
    Works only with lighter figures attempt with Masters.
    It is impossible that the platform can ejact figure, string is to weak.
    The spring is strong enough to knock over a regular masters figure, I have another older video with the bb knocking over stinkor, but the thread won't let me add any more photos or vids, too big a file. I only had this guy out at the time as everything else is away in storage, but you can definitely get this to knock over a heavier figure. Sorry to the other guy who was looking for help, but I don't get notifications about this thread, if anyone wants help in the future send me a pm and I will do my best to help u out, it is very hard to describe how the spring goes back in, hence the series of photos, also hard to get good photos due to the angles of when the unit is half together

  24. #24
    Widget
    Join Date
    Aug 2012
    Location
    Bosnia and Herzegovina
    Posts
    11
    Finaly fix this, but I put spring on another side of platform.

  25. #25
    Oz-Man deviusrme's Avatar
    Join Date
    Apr 2011
    Location
    Brisbane, Australia
    Posts
    39
    Quote Originally Posted by Dinostula View Post
    Finaly fix this, but I put spring on another side of platform.
    If you have any photos, I would love to see other people's fix solutions, glad to see someone was able to get their bb working again, anyone else here with a success story.
    Last edited by deviusrme; August 23, 2012 at 11:26pm.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •